Kurzreferenz der Tabellenfunktionen in Excel
bis zur Version 2016


Helmut Vonhoegen 

www.helmut-vonhoegen.de



Excel wartet mit einer überwältigenden Fülle von Funktionen auf, die aus einem oder mehreren Werten neue Werte ermitteln, und das teilweise auf eine recht komplexe Weise. Eine Funktion ist eine Art Black Box, bei der auf der einen Seite etwas eingegeben wird und auf der anderen Seite etwas herauskommt. Ohne dass der Anwender das oft sehr komplizierte Formelwerk für den Betrieb der Funktion kennen muss, wird ihm nach Eingabe der notwendigen Werte das Ergebnis der Operationen ausgegeben.

Jede Funktion liefert ein Ergebnis. Je nach Funktion kann dieses Ergebnis numerisch sein, also ein bestimmtes Rechenergebnis, eine Zeichenfolge, ein Text oder ein Wahrheitswert (WAHR oder FALSCH). Zuweilen ist das Ergebnis nicht nur ein Wert, sondern eine Matrix (Array) von Werten. Der Typ des Ergebnisses einer Funktion muss berücksichtigt werden, wenn in einer weiteren Formel auf diese Funktion Bezug genommen wird. Ansonsten kommt es eventuell zu einem Fehler, wenn die Datentypen nicht zusammenpassen.

Neue und geänderte Funktionen in Excel 2010

Insbesondere bei den statistischen Funktionen wurden zahlreiche Funktionsnamen geändert, um besser den in diesem Bereich üblichen Bezeichnungen zu entsprechen und die verschiedenen Funktionstypen gleichzeitig deutlicher zu kennzeichnen. Dabei wurden zusammengesetzte Namen eingeführt, bei denen die einzelnen Bestandteile durch Punkte getrennt sind.

Die Funktion FVERT() beispielsweise heißt jetzt F.VERT(). Das Suffix VERT kennzeichnet die Funktion als Verteilungsfunktion. Ähnlich wird das Suffix INV für inverse Funktionen verwendet. F.INV() ersetzt FINV(). Soll die Funktion nicht linksseitig, sondern rechtsseitig verwendet werden, wird noch ein zweites Suffix RE angehängt: F.VERT.RE() und F.INV.RE(). Die alte Funktion FVERT() wird also durch zwei Funktionen ersetzt F.VERT() und F.VERT.RE(), wobei das Ergebnis von F.VERT.RE() dem Ergebnis der alten Funktion entspricht.

Die neuen Funktionen mit dem Suffix VERT haben jetzt alle ein zusätzliches Argument Kumuliert, dessen Wert den Typ der Funktion bestimmt: WAHR liefert einen Wert der Verteilungsfunktion, FALSCH einen Wert der Dichtefunktion.

Bei zweiseitigen Funktionen wird 2S angehängt. Das Suffix P - für Population - beispielsweise in KOVARIANZ.P() - gibt an, dass sich die Funktion auf die Grundgesamtheit bezieht, Suffix S - für sample - wird für Funktionen verwendet, die sich auf eine Stichprobe beziehen. Einige der umbenannten Funktionen haben zugleich zusätzliche Parameter erhalten.

Verbesserte Funktionen

Bei einigen  Funktionen wurden die Algorithmen mit dem Ziel verändert, eine höhere Genauigkeit der Ergebnisse zu gewährleisten oder das Berechnungsverfahren zu beschleunigen. Das gilt z. B. für die mathematischen Funktionen ARCSINHYP(), MOD(), ZUFALLSZAHL(), ZWEIFAKULTÄT(), für einige der statistischen Verteilungsfunktionen, für die finanzmathematischen Funktionen KUMZINSZ() und KUMKAPITAL() und für die technischen Funktionen UMWANDELN(), GAUSSFEHLER() und GAUSSFKOMPL().

Neue Funktionen

Eine Reihe von Funktionen wurde ganz neu oder in einer neuen Variante eingefügt: NETTOARBEITSTAGE.INTL(), ARBEITSTAG.INTL(), AGGREGAT(), OBERGRENZE.GENAU(), UNTERGRENZE.GENAU(), CHIQU.VERT.RE(), CHIQU.INV(), KONFIDENZ.T(), KOVARIANZ.S(), F.VERT(), F.INV(), MODUS.VIELF(),  QUANTIL.INKL(),  QUANTILSRANG.INKL(), QUARTILE.INKL(), RANG.MITTELW(), T.VERT(), T.INV(), GAUSSF.GENAU(), GAUSSKOMPLF.GENAU().

Neue Funktionen in Excel 2013

Excel 2013 bringt eine ganze Reihe von neuen Funktionen. Eine größere Gruppe finden Sie in der Kategorie der mathematischen Funktionen, hauptsächlich Funktionen, die eine Lücke schließen in Bezug auf Dokumente, die im .ods-Format gespeichert werden. Das erleichtert den Austausch dieser Arbeitsmappe mit Anwendern, die Office-Pakete wie Open Office oder Libre Office einsetzen. Dazu gehören eine Reihe von trigonometrischen Funktionen: ARCCOT(), ARCCOTHYP(), COSEC(), COSECHYP(), COT(), COTHYP(). Hinzugekommen sind auch die Funktionen BASIS() und DEZIMAL(), die mit Umwandlungen zwischen Zeichenfolgen und Zahlen zu tun haben, eine Variante für die Kombinatorik:  KOMBINATIONEN2() und MEINHEIT() zur Berechnung der Einheitsmatrix.

Die beiden Funktionen OBERGRENZE.MATHEMATIK() und UNTERGRENZE.MATHEMATIK() ersetzen die in der Version 2010 eingeführten Funktionen OBERGRENZE.GENAU() und UNTERGRENZE.GENAU(). Die älteren Funktionen OBERGRENZE() und UNTERGRENZE() wurden in die Kategorie Kompatibilität verschoben, sollten also in Zukunft möglichst nicht mehr verwendet werden.

Neu unter den finanzmathematischen Funktionen ist PDURATION() zur Berechnung der Anzahl der Perioden, bis eine Investition einen bestimmten angegebenen Zielwert erreicht hat. Außerdem ZSATZINVEST() zur Berechnung des effektiven Jahreszins für den Wertzuwachs einer Investition.

Bei den Datums- und Zeitfunktionen ist nur die Funktion ISOKALENDERWOCHE(), die es jetzt endlich erlaubt, die korrekte Wochenzahl ohne Umstände normgerecht zu ermitteln.

Eine paar neue Funktionen finden Sie in der Kategorie Statistik. Dazu gehören  BINOM.VERT.BEREICH(), GAMMA(), GAUSS(), PHI(), SCHIEFE.P() und VARIATIONEN2() Bei den Verweisfunktionen gibt es die neue Funktion FORMELTEXT(), mit der die Formel in einer Zelle als Text ausgegeben wird, was für den Zweck der Dokumentation manchmal hilfreich sein kann.

Überfällig war in der Kategorie Logik die Funktion XODER(), die die Arbeit mit einem ausschließenden Oder vereinfacht. Neu ist auch WENNNV(), eine Funktion, mit der auf fehlende Werte reagiert werden kann.

Bei den Textfunktionen sind hinzugekommen: UNICODE() und UNIZEICHEN() und mit ZAHLENWERT() eine Funktion zur Konvertierung in Zahlen, unabhängig von dem aktuellen Gebietsschema auf dem System.

Bei den Info-Funktionen gibt es jetzt die neuen Funktionen BLATT() und BLÄTTER(), die ohne Argument die Nummer des aktuellen Blatt und die Zahl der Blätter in einer Arbeitsmappe liefern. Bei den IST…()-Funktionen ist noch die Funktion ISTFORMEL() hinzugekommen.

In der Kategorie Technisch sind fünf Funktionen hinzugekommen, die mit BIT-Operationen zu tun haben: BITVERSCHIEB(), BITODER(), BITRVERSCHIEB(), BITUND() und BITXODER().

In der Gruppe der Funktionen, die mit imaginären Zahlen arbeiten, sind eine Reihe von trigonometrischen Funktionen neu in dieser Version: IMCOSEC(), IMCOSECHYP(), IMCOSHYP(), IMCOT(), IMSEC(), IMSECHYP(), IMSINHYP(), IMTAN().

Ganz neu in Excel 2013 ist eine kleine Gruppe von Funktionen, die in der Kategorie Web zusammengefasst sind: URLCODIEREN() wandelt Zeichenfolgen in gültige Webadressen um, WEBDIENST() liefert Daten aus einem Webdienst zurück und XMLFILTERN() übernimmt aus XML-Dokumenten bestimmte Daten, die über einen XPath-Ausdruck herausgefiltert werden.

Die neuen Funktionen sind mit älteren Versionen von Excel nicht kompatibel. Falls Sie Arbeitsmappen an Arbeitsplätze weiterreichen wollen, die ältere Versionen verwenden, sollten Sie vorher über das Register Datei  auf der Seite Informationen eine Kompatibilitätsprüfung durchführen und unter Umständen Änderungen an den Berechnungsverfahren vornehmen. Beinhaltet Ihre Datei neue Funktionen, werden Sie beim Speichern eine Warnung erhalten.

 

Neue Funktionen in Excel 2016

Mit Excel 2016 wird die Funktion SCHÄTZER() in die Kategorie der kompatiblen Funktionen "verbannt". Stattdessen gibt es eine neue Gruppe von Prognosefunktionen, deren Namen alle mit PROGNOSE beginnen. Diese Funktionen sind auch mit der neuen Funktion Prognoseblatt verknüpft, die über das Register Daten aufgerufen werden kann. Die meisten dieser Funktionen verwenden als Teil des Namens die Abkürzung ETS, die für Enhanced Transmisson Selection steht, ein spezieller Algorithmus für exponentielles Glätten. Im Einzelnen handelt es sich um die Funktionen PROGNOSE.ETS(), PROGNOSE.ETS.KONFINT(), PROGNOSE.ETS.SAISONALITÄT(), PROGNOSE.ETS.STAT() und PROGNOSE.LINEAR().

 

 

Aufbau und Einsatz von Funktionen

Funktionen in Excel sind Anweisungen für Operationen, die das Programm für Sie durchführen soll. Tabellenfunktionen sind Operationen, die innerhalb einer Tabelle benutzt werden, wobei eine derartige Funktion entweder direkt in eine Tabelle eingetragen werden kann oder Bestandteil eines Makros ist, das bezogen auf eine Tabelle abgearbeitet wird.

Eine Funktion benutzt Werte, die als Argumente bereitgestellt werden, um aus ihnen andere Werte zu ermitteln. Dabei kann es sich um einfache oder komplexe Berechnungen handeln, aber auch um logische Analysen, die Zerlegung von Zeichenketten und dergleichen.

Der generelle Aufbau einer Funktion ist:

FUNKTION(Wert...),

wobei für »Wert...« ein oder mehrere Argument(e) stehen können, die die Funktion benötigt.

Argumente für Funktionen

Bei einer Anzahl von Funktionen werden die Argumente noch unterteilt in solche, die erforderlich und solche, die optional sind, also nicht zwangsläufig angegeben werden müssen. Das heißt aber nicht, dass die Funktion ohne die optionalen Argumente in jedem Fall arbeiten würde, sondern dass sie, wenn diese Argumente nicht angegeben werden, vordefinierte Werte für diese Argumente verwendet. Als Argumente einer Funktion kommen in Frage:

Konstanten

Die Werte, mit denen eine Funktion arbeiten soll, werden direkt eingegeben. Wenn Sie z.  B. in eine Zelle

=SUMME(18;15;3)

eintragen,  erscheint in der Zelle das Ergebnis 36.

Bezüge auf Zellen oder Bereiche

Die Werte, mit denen die Funktion arbeiten soll, sind bereits in Zellen oder Bereichen der Tabelle enthalten oder sollen dort eingetragen werden.

Bereichsnamen

Angenommen, Sie haben in einer Tabelle in den Zellen B3 bis B15 die Umsätze für eine Anzahl von Produkten eingetragen und wollen jetzt die Summe dieser Einträge bilden. Wenn Sie dem Bereich B3:B15 etwa den Namen »Umsätze« gegeben haben,  können Sie in das Feld, in dem die Summe stehen soll, einfach eintragen: =SUMME(Umsätze).

Ohne Namen müssten Sie schreiben:

=SUMME(B3:B15).

Funktionen

Schließlich können als Argumente in einer Funktion selber wieder Funktionen verwendet werden, die ihrerseits diejenigen Werte liefern, mit denen die Funktion arbeiten soll. Einfaches Beispiel: =SUMME(SUMME(2;4);SUMME(4;6))

führt zu dem Ergebnis 16.

 

Stehen für ein Argument nur bestimmte Werte zur Auswahl, bietet Excel diese bei der Eingabe in der Bearbeitungsleiste in Form von Auswahllisten an, sobald das Argument an der Reihe ist.

Einige wenige Funktionen (z.  B. PI(), HEUTE(), JETZT()) benötigen keine Argumente. Trotzdem müssen die Klammern immer mitgeschrieben werden, damit Excel die Funktion als solche erkennen kann.

Schreibweise

Bei den Funktionsbeschreibungen ist auf Folgendes zu achten:

Nach dem Funktionsnamen folgt die Darstellung der Syntax der Funktion, d.  h. die Schreibweise der Funktion mit allen Argumenten in der vorgeschriebenen Reihenfolge. Dabei sind die obligatorischen Argumente jeweils fett formatiert.

Folgen auf ein nicht verwendetes optionales Argument weitere Argumente, so ist für jedes ausgelassene Argument ein Semikolon zu setzen.

Bei den Beispielen für die Funktionen werden häufig fixe Werte (Konstanten) als Argumente angegeben. Beim praktischen Gebrauch werden an ihrer Stelle im Allgemeinen Adressen oder Namen stehen.

Werden Tabellenfunktionen innerhalb von Makros aufgerufen, müssen Sie beachten, dass dabei jeweils die englischen Funktionsnamen verwendet werden müssen. Dabei werden im Funktionsnamen verwendete Punkte durch Unterstriche ersetzt.